Archive for April, 2011

Imagelib PutTifFile Function Hangs

Monday, April 25th, 2011

I got hung up for a while recently trying to figure out why the Skyline Tools Imagelib puttiffile function was hanging when I tried to use it to create a multi-page TIFF file from a series of bitmaps.  It took me a long time to figure out that appending to an empty (zero byte) file causes puttiffile to enter an endless loop, while appending to a non-existent file does not.

Go figure!

Anyway, I have bundled up a small test application and sent it to Imagelib technical support.  I will post here when I get a response.

Black Bars When Displaying TIFF Images Using Windows Image Viewer

Monday, April 25th, 2011

I recently discovered that certain TIFF images generated by our document imaging application were showing ugly horizontal black bars when viewed using the Microsoft Image Viewer on Windows 7 and Windows 2008.  Thinking that this just had to be a problem with our imaging system I spent many hours trying this and that to see if I could figure out what the problem was.  I even bundled up the bad images and sent them off to technical support for the imaging tool kit that we use.  All to no avail.

I finally turned to a developer’s best friend (Google) and spent a couple of hours on that before I found out that the black bars are caused by a known bug in the Microsoft Image Viewer.  There is even a hot fix for it. This is all described in KB 2459492.  Downloading and installing the hot fix solved the problem.

One wonders why Microsoft didn’t release this as part of the Windows Update process.